macos 10.12升级ruby到2.2.x以上

mac默认安装的就有ruby,macos10.12默认的ruby版本的事2.0.

在升级前需要安装rvm,

rvm是什么?为什么要安装rvm呢,因为rvm可以让你拥有多个版本的Ruby,并且可以在多个版本之间自由切换。
第一步:安装rvm

等待终端加载完毕,后输入:

如果能显示版本好则安装成功了。

第二步:安装ruby

列出ruby可安装的版本信息

安装一个ruby版本

如果想设置为默认版本,可以用这条命令来完成

查看已安装的ruby

卸载一个已安装ruby版本

第三步:更换源

查看已有的源

显示会如下:

然后我们需要来修改更换源(由于国内被墙)所以要把源切换至淘宝镜像服务器 在终端执行以下命令

 

 

发表评论

电子邮件地址不会被公开。 必填项已用*标注