让阿里云支持ipv6 支持centos7-安全者昨天开始,微魔感冒发烧39度,还到医院挨了一针,很是可怜,今天也没什么心思再寻找促销了,顺便最近在重新再给微魔部落部署ipv6,就给大家再总结一下近期的心得吧。微魔之前曾经发过让Nginx支持ipv6的文章,当时操作的VPS是BuyVM的,这家支持原生(Native)的ipv6,所以不用多说,只需要提交一个tk,ipv6地址就帮你部署了,但是,像阿里云这样的VPS(不支持原生ipv6)该肿么办呢?好吧,不绕弯子了,大家可以通过HE.NET提供的Tunnel Broker这个所谓的ipv6的隧道间接的让自己的VPS支持ipv6。当然本文的方法很多朋友见过,高手勿笑~另外该方法普遍通用于其他的VPS~

让阿里云支持ipv6(其他多数VPS通用)

1.注册Tunnel broker(略去)

官网链接

2.创建通道“Create Regular Tunnel”,填写VPS的ip以及选择默认的隧道节点,点击Create Tunnel创建

填写ip都,如果出现“IP is a potential tunnel endpoint.”则证明可以添加ipv6隧道,一般隧道节点系统已经默认分配,但可以手动选择,大家可以根据自己的实际情况操作

让阿里云支持ipv6 支持centos7-安全者
3.到下一页面切换到Example configurations选项卡,如果你的VPS是centOS/Debian这些常见Linux的话,下拉菜单选择Linux-route2,出现了设置的命令,复制下来在,到自己的VPS上运行。
让阿里云支持ipv6 支持centos7-安全者
4.在自己VPS下运行如下命令,如能见到自己之前的ipv6的ip,如X:X:X:X::2即成功了~